Login - 1829 users online  

  

¿Como sincronizar subtitulos a archivos matroska (.MKV) y archivos .MP4?





Thread creado por cherrycheshire el 26/01/2011 02:30:11 am. Lecturas: 13,211. Mensajes: 5. Favoritos: 0






26/01/2011 02:30:11 am 
           0                           
cherrycheshire


Miembro desde: 26/01/2011

Threads abiertos: 1
Mensajes: 2  
Subtítulos subidos: 0
Threads Favoritos: 0





Tengo dos películas una en formato .MKV y otra en .MP4, ambas sin subtítulos ... intente editarles subtítulos en formato .SRT q encontré en la red ( pues algunas lineas están mal traducidas o sin traducir )

Pero el Subtitle Workshop se me vuelve loco abre los vídeos sin audio o con el audio atrasado y de sincroniza los subtítulos ( ya había comprobado q estaban bien sincronizados reproduciendolos con el Media player classic ).

El Subtitle Workshop no trabaja con archivos .MKV - .MP4 ?? q programa para editar/sincronizar subtitulos puedo utilizar q si los soporte ??

O el problema es de conflicto entre los archivos de video y la extension de los subtitulos (srt) ?? debo cambiarles de extension ??

No quiero sacificar la calidad de los videos convirtiendolos a .Avi para acabar con el problema

Help meeeeeeeeee ¡¡¡¡


26/01/2011 11:39:25 am 
           1                           
Si trabaja por lo menos con MKV el problema son la configuracion de los codecs

No me he metido a solucionarlo porque en un compu con XP de la oficina me funca perfecto pero el de la casa con Win7 No me funca.

cuando no lo estoy en la oficina lo que hago es sincronizo con ayuda de alguno que encuentre sincronizado en otro idioma o extrayendo alguno que venga dentro del MKV


26/01/2011 02:26:18 pm 
           1                           
Al comienzo tuve el mismo problema que tu, y me iba desesperando tratando de encontrar una solución, pero hoy día me trabaja bien (el subtitle workshop) para la mayoría de películas, pero debes tener instalado en el pc el haali media splitter y los filtros ffdshow.
A los filtros toca configurarlos para que trabajen junto con el subtitle workshop y cuando se abre una película MKV o MP4 con el subtitle workshop, se cargan los filtros y el haali media spliter en los iconos de abajo a la derecha del escritorio.

Aunque de me he topado con una pocas películas en las que efectivamente se queda el sonido atrás (aunque corran bien en el vlc media player), según he leído esto se debe a que los filtros usan un codec llamado livabcodec para los archivos de H264 que es un poco lento, en un pc mejor supongo que no dan problema.

Entonces por lo general uso el VLC para ver archivos MKV y mp4 que no da problema y trae sus codecs incorporados.
El haali media spliter y los filtros ffshow se abren cuando uso el BSplayer o el subtitle workshop con un archivo MKV y las películas que me he topado en las que se descuadra el audio, funcionan bien en el VLC, pero se descuadran cuando las abro con el BSplayer o con el Subtitle Workshop, por eso se que se debe a los filtros y al rendimiento del PC.

También se que está a la venta un codec que es según dicen es más rápido rápido para los archivos h264 llamado CoreAVC, no se si consigue por ´´otros medios´´, la verdad no he buscado, pues con la configuración que tengo no he tenido casi problemas.

En mundodivx puedes bajar los filtros y hay más información.


26/01/2011 03:37:47 pm 
           3                           
con este se pueden los mkv DivXLand Media Subtitler


28/01/2011 10:01:33 pm 
           0                           
cherrycheshire


Miembro desde: 26/01/2011

Threads abiertos: 1
Mensajes: 2  
Subtítulos subidos: 0
Threads Favoritos: 0





Gracias a todos ... Lo q hice fue instalar un nuevo paquete de codecs .. el K-Lite CodePack 6.9.0 q incluye los filtros ffshow de los q hablaba @Tobisama ( ... capaz q todos los paquetes de codecs lo traen y yo hasta ahora me entero)

Luego en la configuracion del DirectVobSub, fui a la pestaña ´´general´´, y en la parte de ´´loading´´, seleccione ´´do not load´´ pues segun lei en alguna parte es lo q ocasiona conflictos al subtitle workshop y al DivXLand Media Subtitler ... y oh maravilla ambos funcionan perfecto tanto con .mp4 como con .mkv

El unico lio q tengo ahora es q a ratos cuando estoy trabajando en la edicion y sincronizacion de los subtitulos la pantalla empieza a titilar como loca y al rato vuelve a la normalidad ... tal vez configure algo mal ?? problemas con la tarjeta de video ?? en fin , mi discapacidad tecnologica es abismal , pero se hace el intento




Otros threads relacionados


archivos

0