Login

  

Conservar canales al convertir ac3 en VirtualDub





Thread creado por Hope95 el 02/03/2012 06:23:41 pm. Lecturas: 2,479. Mensajes: 5. Favoritos: 0





02/03/2012 06:23:41 pm 
       0                           
Hope95


Miembro desde: 02/03/2012

Threads abiertos: 1
Mensajes: 4  
Subtítulos subidos: 0
Threads Favoritos: 0





Hola a todos les traigo un problemita que estoy teniendo al convertir un .mkv con ac3 (6 canales) a .avi en el VirtualDub usando el codec xvid mpeg4 para pegarle subt韙ulos.
Con el video no tengo ningun problema, se me pegan los subs pero si al audio le pongo 创Direc stream copy创 me da como resultado un waw PCM de 2 canales
Por el otro lado, si intento convertirlo a 5.1 en ac3 solo lo puedo convertir en est閞eo y mono, las otras opciones para que aparezcan tengo que darle a 创show all formats创 en compression y me las acepta pero cuando empiezo me dice 创Error initializing audio stream compression:
The audio codec cannot compress the source to the desired format.
Check that the sampling rate and number of channels in the source is compatible with the selected compressed audio format创.
Tampoco funciona con DTS, me da el mismo error

Alguna manera de conservar los canales? no importa en que formato
Tengo el ac3filter instalado, el k-lite, ffdshow, xvid, avisynth y gordian knot rip pack 0.35 Todo lo necesario para que la parte de video no me de problemas

Espero sus respuestas border="0" src=img/foro/grin.gif>


02/03/2012 06:53:16 pm 
       1                           
carlosdek


Miembro desde: 27/04/2009

Threads abiertos: 49
Mensajes: 2211  
Subtítulos subidos: 74
Threads Favoritos: 0





Debes pasar el Audio a formato AAC.

Luego se une con YAMB o usando alg鷑 comando de linea.

ffmpeg -i testvideo.mp4 -i testvideo.m4a -vcodec copy -acodec copy TestVideoMux.mp4

o

mencoder -oac copy -ovc copy -o 创output.avi创 -audiofile 创input-audio.mpa创 创input-video.avi创


Suerte


03/03/2012 11:01:33 am 
       0                           
Hope95


Miembro desde: 02/03/2012

Threads abiertos: 1
Mensajes: 4  
Subtítulos subidos: 0
Threads Favoritos: 0





carlosdek escribi:
Debes pasar el Audio a formato AAC.

Luego se une con YAMB o usando alg鷑 comando de linea.

ffmpeg -i testvideo.mp4 -i testvideo.m4a -vcodec copy -acodec copy TestVideoMux.mp4

o

mencoder -oac copy -ovc copy -o 创output.avi创 -audiofile 创input-audio.mpa创 创input-video.avi创


Suerte border="0" src=img/foro/wave.gif> border="0" src=img/foro/wave.gif> border="0" src=img/foro/wave.gif>


No puedo convertir en aac tampoco border="0" src=img/foro/weep.gif>

He probado sacando el audio en aac con el Oxelon Media Converter y me queda en 6 canales
Pero al unirlo con el yamb le bajan los fps al video y le aparecen algunos errores
Con los comandos va a funcionar de esa manera? asi aprendo como usar comandos


03/03/2012 11:10:29 am 
       0                           
Hope95


Miembro desde: 02/03/2012

Threads abiertos: 1
Mensajes: 4  
Subtítulos subidos: 0
Threads Favoritos: 0





Pongo los datos del video mkv con el mediainfo
Video
ID : 1
Formato : AVC
Formato/Info : Advanced Video Codec
Formato del perfil : High@L3.1
Ajustes del formato, CABAC : No
Ajustes del formato, RefFrames : 2marcos
Format_Settings_GOP : N=1
ID C骴ec : V_MPEG4/ISO/AVC
Duraci髇 : 22min.
Tasa de bits : 3 947Kbps
Ancho : 1 280pixeles
Alto : 720pixeles
Relaci髇 de aspecto : 16:9
Velocidad de cuadro : 23,976fps
ColorSpace : YUV
ChromaSubsampling : 4:2:0
BitDepth/String : 8bits
Tipo de exploraci髇 : Progresivo
Bits/(Pixelcuadro) : 0.179
Tama駉 de pista : 622MB (89%)
Idioma : Ingl閟
Default : Si
Forced : No
colour_primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
transfer_characteristics : BT.709-5, BT.1361
matrix_coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio
ID : 2
Formato : AC-3
Formato/Info : Audio Coding 3
Format_Settings_ModeExtension : CM (complete main)
ID C骴ec : A_AC3
Duraci髇 : 22min.
Tipo de tasa de bits : Constante
Tasa de bits : 384Kbps
Canal(es) : 6canales
Posiciones del canal : Front: L C R, Side: L R, LFE
Velocidad de muestreo : 48,0KHz
BitDepth/String : 16bits
Tama駉 de pista : 60,6MB (9%)
Idioma : Ingl閟
Default : Si
Forced : No


03/03/2012 07:38:42 pm 
       0                           
Hope95


Miembro desde: 02/03/2012

Threads abiertos: 1
Mensajes: 4  
Subtítulos subidos: 0
Threads Favoritos: 0





Ya lo solucion, convirtiendo solo el video sin audio. Pare eso puse en un block de notas DirectShowSource(创filename.mkv创, audio=false) en 创filename.mkv创 va el nombre del archivo y lo gaurde con la extenci髇 .avs y despues lo abri con el virtualdubmod y le pegue el audio que habia sacado con el Oxelon Media Converter
Espero que le sirva a alguien que tenga este problema






convertir

1